红线连连选股公式及告成率回测数据


发布日期:2022-09-07 00:31    点击次数:111


​条件选股:红线连连[日线]告成率测试

测试股票数:4624

共收回旗子灯号:460950告成旗子灯号:204290失利旗子灯号:253953未实现旗子灯号:2707

旗子灯号收回率:94.68%匀称告成率:44.58%告成率达到50%的股票数有:38.49%

利润1总匀称:14.09%最大匀称利润1:  337.52%  最小匀称利润1:  0.00%

利润2总匀称:1.40%最大匀称利润2:  278.08%  最小匀称利润2: -55.05%

公式翻译:

量比赋值:成交量(手)/1日前的成交量(手)涨幅赋值:1日前的收盘价/8日前的收盘价振幅赋值:15日内1日前的最低价的最高值/15日内1日前的最自制的最低值每日涨幅赋值:(收盘价-1日前的收盘价)/1日前的收盘价*100每日跌幅赋值:(1日前的收盘价-收盘价)/1日前的收盘价*100价位黑马赋值:统计10日中餍足收盘价>=收盘价的天数>8 AND 统计10日中餍足1<每日涨幅<6的天数>=5 AND 统计10日中餍足每日涨幅的绝对于值<=5的天数>=9价格冲破赋值:统计10日中餍足1日前的每日涨幅的绝对于值>=5的天数<1 AND 每日涨幅>4 AND 统计11日中餍足统计3日中餍足1日前的每日涨幅<0的天数=3的天数<1 AND 振幅<=1.20 AND 涨幅>0.95红线连连赋值:统计7日中餍足收阳线的天数=7 OR 统计10日中餍足收阳线的天数>8 AND 统计10日中餍足每日涨幅的绝对于值<=5的天数>=10红线连赋值:统计15日中餍足收阳线的天数>=11 AND 统计15日中餍足统计3日中餍足收阴线的天数=3的天数=0 AND 统计10日中餍足每日涨幅的绝对于值<=5的天数>=10价位黑马 OR 价格冲破 OR 红线连连 OR 红线连

公式源码:

量比:=V/REF(V,1);

涨幅:=REF(C,1)/REF(C,8);

振幅:=HHV(REF(H,1),15)/LLV(REF(L,1),15);

每日涨幅:=(C-REF(C,1))/REF(C,1)*100;

尊享服务 35, 35);">每日跌幅:=(REF(C,1)-C)/REF(C,1)*100;

价位黑马:=COUNT(C>=O,10)>8 AND COUNT(1<每日涨幅<6,10)>=5 AND COUNT(ABS(每日涨幅)<=5,10)>=9;

价格冲破:=COUNT(ABS(REF(每日涨幅,1))>=5,10)<1 AND 每日涨幅>4 AND COUNT(COUNT(REF(每日涨幅,1)<0,3)=3,11)<1 AND 振幅<=1.20 AND 涨幅>0.95;

红线连连:=COUNT(C>O,7)=7 OR COUNT(C>O,10)>8 AND COUNT(ABS(每日涨幅)<=5,10)>=10;

红线连:=COUNT(C>O,15)>=11 AND COUNT(COUNT(C<O,3)=3,15)=0 AND COUNT(ABS(每日涨幅)<=5,10)>=10;

红线连连:价位黑马 OR 价格冲破 OR 红线连连 OR 红线连;

本站是供应集团知识打点的网络存储空间,全体内容均由用户宣布,不代表本站概念。请留心甄别内容中的联络要领、诱惑置办等信息,谨防诳骗。如缔造有害或侵权内容,请点击一键告发。